ArcGIS Server: “Cannot authenticate supplied identity” Error

So, I get this error from time to time in a dev environment or, occasionally, on a client’s server. It used to be very, very frustrating to solve, so I created a checklist of things that worked. I am writing it here to help others, hopefully, and make sure I never forget these steps.  I always try them in the following order.

  1. Make sure the ArcGISWebServices account password has not expired.  If you are comfortable with it, set this password to never expire.  This, more often than not, is the root cause of the issue.
  2. We have seen an issue where having the I_USR account in the “Guests” group on the box caused this error.  Not sure why, but the SA couldn’t tell me why that user was in that group either.Add ArcGISWebServices user to the Power Users group and restart the WWW service.  Again, this may be out of your security comfort zone.  If it is the problem, then you’ll need to mess with the privileges of that account until you find the issue.  Also, I’ve seen this not work until I deleted the user, reran the Post Install and THEN added them to the group.
  3. If it’s still an issue, time to get nasty.  Delete your ArcGISWebServices user and rerun the Web Applications Post Install.  This will force you to create a new ArcGISWebServices user.
  4. Last resort.  Do all the stuff in this thread, as well as the thread that is linked therein.  This is the “throw all the crap against the wall and hope something sticks” step.

Hopefully, that’ll get it done.  If not, and you find something else that works, please let me know.  I don’t run into this issue very often any more (but I did today and step 1 fixed it) but when I do, I am glad I have a checklist.

Advertisements

About Ruprict

I am a nerd that is a Nerd Wannabe. I have more kids than should be allowed by law, a lovely wife, and a different sense of humor than most. I work in the field of GIS, where I am still trying to find myself on the map. View all posts by Ruprict

2 responses to “ArcGIS Server: “Cannot authenticate supplied identity” Error

  • Jess Borrevik

    Thanks so much for your post. I’ve been stuck on this for close to a week. I’m working with Esri support, so far no luck.

    Quick question(s) …in step #2, ArcGIS Server Post Install? Web app post install? or both?

    Also, any potential side affects from removing this account from ‘Guests’? I do see we have I_USR_[server name] in the list …

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: